New version 0.5.0-beta4 is out

Keep up to date with EG related information here.
Post Reply
User avatar
blackwind
Experienced User
Posts: 182
Joined: Wed Sep 12, 2012 2:59 am
Location: Canada
Contact:

New version 0.5.0-beta4 is out

Post by blackwind » Wed Sep 14, 2016 6:20 am

0.5.0-beta4 (2016-09-14)

Enhancements:
  • Register restart handler for easy crash recovery #103 (blackwind)
Fixed bugs:
  • Make automatic log scrolling work at all window sizes #98 (blackwind)
  • Make plugin export work for non-English users #101 (blackwind)
  • Prevent traceback in PyCrust when a plugin imports its own modules #102 (blackwind)
  • Open plugin installer even if program isn't running #104 (blackwind)
  • [Window] Prevent random traceback on Grab Text Item(s) action #105 (blackwind)
Just putting out the last of my unreleased changes for the benefit of the community.

This will be the final release of EventGhost under zian's reign.

Frequently Asked Questions:

Q: Why aren't some of my events working?
A: You were using implicit wildcards. A "Play" event, for example, would previously match "X10Mouse.Button.Play" and "MyRemote.Play". In v0.5, you need to use explicit wildcards like "*.Play".

Q: Why are certain Python modules I depend on missing?
A: See #20. TL;DR: You can now use any module you want by installing it yourself.

Q: Why am I getting an error about `AddGrowableCol()`?
A: You're using plugins that haven't yet been updated for v0.5. If you're a regular user, roll back to v0.4.1r1722 for now; if you're a plugin developer, see #35 for info on how to update your plugins. If you need further assistance, post a reply to #35.
/bw

kalinkamaen
Experienced User
Posts: 133
Joined: Wed Dec 26, 2012 9:23 am

Re: New version 0.5.0-beta4 is out

Post by kalinkamaen » Thu Sep 15, 2016 7:13 am

I just want you to know that I support your decision. And I wish you good luck with new projects.
I am happy that you tried, but it is worthless when we have a leader that only thinks about him self
and not about the community. To have a leader that doesnt know how to do the job is the same as having
a dentist as a leader for a workshop. He will never get the respect from his workers that he needs to, to be a good leader.
Its a shame, but its true!

Regards Kali

Sem;colon
Experienced User
Posts: 582
Joined: Sat Feb 18, 2012 10:51 am
Location: Germany

Re: New version 0.5.0-beta4 is out

Post by Sem;colon » Fri Sep 16, 2016 7:32 pm

thx blackwind!
I very appreciate, beta 4 works great!
You are welcome to come back to the project any time! :)

jjaimungal
Posts: 1
Joined: Wed Oct 05, 2016 1:00 pm

Re: New version 0.5.0-beta4 is out

Post by jjaimungal » Wed Oct 05, 2016 1:07 pm

Is the Pulse-Eight CEC adapter still supported?
I upgraded one of my devices to see whats coming down with the new version and my CEC portions now error out.
Also, it does not show Pulse-Eight in the plugins list, just "libCEC". I have tried uninstalling and reinstalling libCEC package with the EG plugin

Post Reply