Setting up EventGhost and PC

If you have a question or need help, this is the place to be.
Post Reply
trickyrick
Posts: 11
Joined: Mon Jul 16, 2018 4:32 pm

Setting up EventGhost and PC

Post by trickyrick » Mon Jul 16, 2018 4:38 pm

I have Eventghost on my PC and I have the Smartapp installed in Smartthings with the EventGhost server being 10.0.0.9. I would like to trigger an mp3 on my PC when a switch is turned on
I have tried to follow a couple tutorials I found but they seem to skip over things
Im stuck any pointers would be appreciated

User avatar
kgschlosser
Site Admin
Posts: 4050
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Setting up EventGhost and PC

Post by kgschlosser » Mon Jul 16, 2018 5:40 pm

OK. So what I am gathering is you want to cause an event in EventGhost from SmartThings.

I know nothing about SmartThings. I am pretty sure it has the ability to send web requests.

So this is what you need to do.
Install the Web Server plugin into EG (EG comes with it)
Setup the Web Server to whatever port you want to use.

then from SmartThings send a web request formatted like so (or you can test it with a browser)


http:\\192.168.1.1:8080\index.htm?SomeEvent

and that should do the trick
If you like the work I have been doing then feel free to Image

trickyrick
Posts: 11
Joined: Mon Jul 16, 2018 4:32 pm

Re: Setting up EventGhost and PC

Post by trickyrick » Mon Jul 16, 2018 6:21 pm

Thanks
Got it working

trickyrick
Posts: 11
Joined: Mon Jul 16, 2018 4:32 pm

Re: Setting up EventGhost and PC

Post by trickyrick » Mon Jul 16, 2018 6:23 pm

Thanks
I have it installed on a PC running Win7 when I do anything within EventGhost like click on new the program crashes
Any idea whats up with that

holdestmade
Experienced User
Posts: 132
Joined: Thu Dec 04, 2014 2:44 pm

Re: Setting up EventGhost and PC

Post by holdestmade » Mon Jul 16, 2018 7:20 pm

Hi,

I've recently started using smartthings, mainly because my new Samsung TV has an app to control the hub from the remote on an on-screen interface.

I use eventghost for lots of things and have started using the ST smartapp "Send events to Eventghost".

Basically it sends any events your select in ST to a webserver that you set up on EG and events pop up in the EG log window.

Works really well, I currently use it for turning on and off Yeelight bulbs with a ST virtual switch.

A 2-way ST smartapp / EG plugin would be great but this works great for now.

trickyrick
Posts: 11
Joined: Mon Jul 16, 2018 4:32 pm

Re: Setting up EventGhost and PC

Post by trickyrick » Mon Jul 16, 2018 9:17 pm

Thanks
Im having a problem with EventGhost on my PC the program runs but as soon as I click on new it crashes and I have to open it again and again and again. I installed the program on my laptop and configured it with my macros saved the file and I was able to open it on my desktop PC. It worked for a few hours but when I went back to check it had crashed. Im running win7 with the latest version of EG.
Any suggestions

User avatar
kgschlosser
Site Admin
Posts: 4050
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Setting up EventGhost and PC

Post by kgschlosser » Tue Jul 17, 2018 3:21 am

ya have to give me some more information then that. does it display an app crash message? Does the process get stuck?
If you like the work I have been doing then feel free to Image

trickyrick
Posts: 11
Joined: Mon Jul 16, 2018 4:32 pm

Re: Setting up EventGhost and PC

Post by trickyrick » Tue Jul 17, 2018 3:52 am

When the program starts it would run ok until i click on new. The program would crash or close. I found an old post in the bug section that suggested I delete the config file under appdata\roaming\eventhost
I did that and everything seems to be ok
Im not sure what that had to do with it
Rick

User avatar
kgschlosser
Site Admin
Posts: 4050
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: Setting up EventGhost and PC

Post by kgschlosser » Tue Jul 17, 2018 4:39 pm

it could have gotten corrupted. we fixed an issue with how the config file gets written in the latest none public build of EG.
If you like the work I have been doing then feel free to Image

Post Reply