Audio error

If you have a question or need help, this is the place to be.
Post Reply
steveh8758
Posts: 1
Joined: Sun Feb 04, 2018 7:49 am

Audio error

Post by steveh8758 » Sun Feb 04, 2018 8:00 am

I have problems when I run audio command
could someone help me solve this problem? thx


----------------------------------------------------------------------------------
Error in Action: "Turn Mute On"
Traceback (most recent call last) (0.5.0-rc4):
File "C:\Program Files (x86)\EventGhost\eg\Classes\ActionBase.py", line 116, in CallWrapper
return self(*args)
File "C:\Program Files (x86)\EventGhost\plugins\System\__init__.py", line 1971, in __call__
SoundMixer.SetMute(True, deviceId)
File "C:\Program Files (x86)\EventGhost\eg\WinApi\SoundMixer.py", line 506, in SetMute
deviceId = GetDeviceId(deviceId)
File "C:\Program Files (x86)\EventGhost\plugins\System\__init__.py", line 101, in GetDeviceId_
id = oldGetDeviceId(*args, **kwargs)
File "C:\Program Files (x86)\EventGhost\eg\WinApi\SoundMixer.py", line 275, in GetDeviceId
raise SoundMixerException()
-----------------------------------------------------------------------------------

I've already tried "0.4.1.r1722" "0.5.0-rc4" "0.5.0-rc3" "0.5.0-rc2" version
but have same error
OS:win7 ultimate 64 service pack 1

blaher
Experienced User
Posts: 494
Joined: Thu Nov 17, 2011 1:27 am

Re: Audio error

Post by blaher » Fri Feb 09, 2018 2:57 am

Are you muting the right device? Delete the 'mute' action and re-add it, so you can specify the right audio device you want to mute.

Post Reply