EG sometimes not detecting remote clicks, need restart

If you have a question or need help, this is the place to be.
Post Reply
jang430
Experienced User
Posts: 55
Joined: Fri Dec 21, 2012 8:24 am

EG sometimes not detecting remote clicks, need restart

Post by jang430 » Sat Jan 07, 2017 3:32 pm

Hi, I have EG started on pc startup. There are plenty of times, after watching kodi on extended monitor, I will turn off external monitor (which is actually a TV), leave it for a day, upon clicking my remote, it ko longer works. Kodi still functional, didn't hang. I need to restart, then all will work again. After a day, same thing will happen.

I am using Windows 10 professional. What's wrong? I have tried closing EG, and starting it once again without restart, but it won't work.

User avatar
topix
Experienced User
Posts: 381
Joined: Sat May 05, 2007 3:43 pm
Location: Germany
Contact:

Re: EG sometimes not detecting remote clicks, need restart

Post by topix » Sun Jan 08, 2017 8:14 am

Can you give more information? What EventGhost version, what plugins you're using? It might be that not EG is hanging, instead the driver of your remote control.

User avatar
kgschlosser
Site Admin
Posts: 3113
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: EG sometimes not detecting remote clicks, need restart

Post by kgschlosser » Sun Jan 08, 2017 11:34 am

Is the computer going to sleep at all??? this has been known to cause issues on some computers due to the USB having it's power turned off. you can change this setting in your device manager for the USB Hub.

I would start there. even if the computer does not go to sleep if there are power saving features turned on for the USB there is a strong chance this is the issue.

K
If you like the work I have been doing then feel free to Image

jang430
Experienced User
Posts: 55
Joined: Fri Dec 21, 2012 8:24 am

Re: EG sometimes not detecting remote clicks, need restart

Post by jang430 » Sun Jan 08, 2017 11:51 am

Hi. I'm using EG 0.4.1.r1722. I prevent PC from going into sleep. Will go to device manager/ USB Hub.

Thanks for the answers for now.

perezbalen
Posts: 5
Joined: Sun Feb 15, 2015 4:11 pm

Re: EG sometimes not detecting remote clicks, need restart

Post by perezbalen » Sat Jan 14, 2017 2:53 pm

Having the same problem.

When the computer wakes from sleep, sometimes the events interpreted weird (allways something different). I need to restart EventGhost for them to get interpreted ok. Sometimes it even happens without the computer going to sleep at all.
I'm using EG 0.4.1.r1722.
After reading the post, I changed the USB Root Hub (xHCI) "Allow the computer to turn off this device to save power" to unchecked, but it did not help.

User avatar
topix
Experienced User
Posts: 381
Joined: Sat May 05, 2007 3:43 pm
Location: Germany
Contact:

Re: EG sometimes not detecting remote clicks, need restart

Post by topix » Sat Jan 14, 2017 7:40 pm

perezbalen wrote:When the computer wakes from sleep, sometimes the events interpreted weird (allways something different).
What does 'interpreted weird' mean? Can you post a screenshot of those events (and eventually how they should be correct)?

User avatar
kgschlosser
Site Admin
Posts: 3113
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: EG sometimes not detecting remote clicks, need restart

Post by kgschlosser » Sat Jan 14, 2017 10:00 pm

ok to make sure we are all on the same page here

go into your Power Options in control panel
then click on change plan settings for the power plan you have chosen
ControlPanelPowerOptions.png

in the next window click on change advanced power settings
CustomPlan.png

then under the usb settings change the selective suspend to disabled
PowerOptions.png
then go back to control panel and go into device manager
under the universal serial bus controllers
DeviceManager.png
you will have to do this for each of the USB Root Hubs shown. but you need to go into the properties
under the power management tab uncheck the turn off device to save power
USBPower.png
this will make sure the usb is not getting shut down. because even if the computer does not sleep windows will still shut off power to it.
If you like the work I have been doing then feel free to Image

User avatar
kgschlosser
Site Admin
Posts: 3113
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA

Re: EG sometimes not detecting remote clicks, need restart

Post by kgschlosser » Sat Jan 14, 2017 10:09 pm

and this device USB Root Hub (xHCI)
is USB 3.0 so unless you have your ir receiver plugged into a usb 3.0 port (usually marked a different color on the computer) it wouldn't do anything for it.. you have to change the settings for anything that states USB Root Hub

follow the tutorial above.. and lets see if we can't narrow this bugger down..

this is a trial and error thing. I do have 2 questions tho

have you upgrading the plugin. this is the support forum for the plugin.. there are releases and bug fixes here..
viewtopic.php?f=9&t=6044

and in this link if you read down you will find a post by me with some instruction on how to reset the driver installation, this seems to fix a whole lot of issues.
viewtopic.php?f=9&t=6044&start=180#p42510
If you like the work I have been doing then feel free to Image

Post Reply