My configuration tree is broken after trying to update EG

Found a bug in EventGhost? Report it here.

My configuration tree is broken after trying to update EG

Postby hyseptik » Wed Apr 05, 2017 9:31 am

I spent months configuring advanced automation little by little. Recently I discovered, while manually looking for EventGhost updates, that there was a beta version out (0.5.0-beta4). Stupidly, I tried to simply install it by overwriting the previous version (0.4.1.r1722). After doing that, my AutoRemote plugin stopped generating events, and I tried reinstalling it (only the plugin). After a short while I started getting bunches of error messages, and I couldn't even exit EventGhost properly (it gave this error)!

After reinstalling EventGhost (after first completely removing previous versions) several times without help, I am now running 0.4.1.r1722 again. What finally seemed to work was creating a new tree. As long as I don't load the old configuration tree everything seems to work as normal. If I load the old tree, the AutoRemote stops generating events, and pretty much anything can crash EventGhost. I can't exit (same error as above), and trying to configure plugins seems to crash EventGhost most of the time.

Now I'm wondering; how can I salvage my old project? I really don't want to set up everything again manually. That would take days, and I would have to open the old config to check how I did things, which would crash EventGhost several times and cause major delays.

Please advise.
hyseptik
 
Posts: 1
Joined: Sat Feb 14, 2015 1:16 am

Re: My configuration tree is broken after trying to update E

Postby kgschlosser » Wed Apr 05, 2017 12:29 pm

Ok. I need A copy of the save file. I also need you to run EventGhost from the command line. Like this

Code: Select all
eventghost -debug


Do this multiple times. Get EG to crash. But also make sure you exit EG as well and get it to hang. After you do this. Open file explorer and key this into your address bar
%appdata%\roaming\eventghost
In that folder will be log.txt
I need a copy of that file as well
If you like the work I have been doing then feel free to Image
User avatar
kgschlosser
Site Admin
 
Posts: 2341
Joined: Fri Jun 05, 2015 5:43 am
Location: Rocky Mountains, Colorado USA


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 7 guests