Page 1 of 1

X10 Plugin Fehler in Version 0.3.7.r851

Posted: Fri Mar 20, 2009 9:28 pm
by Prinz
Hallo,

in das X10-Plugin der Version r851 hat sich leider ein Fehler eingeschlichen:

In der Zeile 238 steht ab Version r851:

Code: Select all

remoteId = REMOTE_IDS[(lAddress / 4) * 4]
Richtig ist aber:

Code: Select all

remoteId = REMOTE_IDS[(lAddress >> 4) << 4]
Gruß
Prinz

Re: X10 Plugin Fehler in Version 0.3.7.r851

Posted: Wed Apr 29, 2009 8:45 pm
by Bitmonster
=> 0.3.7.r918