[FIXED] Fehlermeldung beim Start von EventGhost (0.3.6.1359)

Einen Fehler gefunden? Gleich hier melden!
Post Reply
tjg
Experienced User
Posts: 67
Joined: Sat Feb 11, 2006 4:11 pm

[FIXED] Fehlermeldung beim Start von EventGhost (0.3.6.1359)

Post by tjg » Sun Apr 06, 2008 7:45 am

Hallo,

beim Starten kommen folgende Fehlermeldungen:

pythoncom error: ERROR: server.policy could not create an instance.

Traceback (most recent call last):
File "win32com\server\policy.pyc", line 144, in CreateInstance
File "win32com\server\policy.pyc", line 202, in _CreateInstance_
File "win32com\server\policy.pyc", line 739, in call_func
File "win32com\server\policy.pyc", line 728, in resolve_func
File "win32com\server\policy.pyc", line 747, in _import_module
<type 'exceptions.ImportError'>: No module named WinAPI.COMServer
pythoncom error: Unexpected gateway error

Traceback (most recent call last):
File "win32com\server\policy.pyc", line 144, in CreateInstance
File "win32com\server\policy.pyc", line 202, in _CreateInstance_
File "win32com\server\policy.pyc", line 739, in call_func
File "win32com\server\policy.pyc", line 728, in resolve_func
File "win32com\server\policy.pyc", line 747, in _import_module
<type 'exceptions.ImportError'>: No module named WinAPI.COMServer
pythoncom error: CPyFactory::CreateInstance failed to create instance. (80004005)
Unable to establish COM disptach!
Last edited by tjg on Mon Apr 07, 2008 12:37 pm, edited 2 times in total.

User avatar
Bitmonster
Site Admin
Posts: 2239
Joined: Mon Feb 06, 2006 10:28 pm

Re: Fehlermeldung beim Start von EventGhost (0.3.6.1359)

Post by Bitmonster » Sun Apr 06, 2008 12:46 pm

Vista?
Please post software-related questions in the forum - PMs will only be answered, if really private, thanks!

tjg
Experienced User
Posts: 67
Joined: Sat Feb 11, 2006 4:11 pm

Re: Fehlermeldung beim Start von EventGhost (0.3.6.1359)

Post by tjg » Sun Apr 06, 2008 2:48 pm

...ja, Vista SP1

User avatar
Bitmonster
Site Admin
Posts: 2239
Joined: Mon Feb 06, 2006 10:28 pm

Re: Fehlermeldung beim Start von EventGhost (0.3.6.1359)

Post by Bitmonster » Sun Apr 06, 2008 3:18 pm

Versuch mal 1370.
Please post software-related questions in the forum - PMs will only be answered, if really private, thanks!

tjg
Experienced User
Posts: 67
Joined: Sat Feb 11, 2006 4:11 pm

Re: Fehlermeldung beim Start von EventGhost (0.3.6.1359)

Post by tjg » Mon Apr 07, 2008 5:14 am

...hat nicht geholfen (habe Version 1371 verwendet)

Fehlermeldung:

Channellist
DVBViewer: Channellist
Fehler in Befehl: "DVBViewer: Channellist"
Traceback (most recent call last) (1371):
File "D:\EventGhost\eg\Classes\ActionClass.py", line 155, in CallWrapper
File "D:\EventGhost\plugins\DVBViewer\__init__.py", line 318, in __call__
File "D:\EventGhost\plugins\DVBViewer\__init__.py", line 355, in SendCommandThroughCOM
File "win32com\client\dynamic.pyc", line 496, in __getattr__
AttributeError: DVBViewerServer.DVBViewer.SendCommand
Close DVBViewer
Deaktiviere: DVBViewer
DVBViewer: Close DVBViewer
Fehler in Befehl: "DVBViewer: Close DVBViewer"
Traceback (most recent call last) (1371):
File "D:\EventGhost\eg\Classes\ActionClass.py", line 155, in CallWrapper
File "D:\EventGhost\plugins\DVBViewer\__init__.py", line 318, in __call__
File "D:\EventGhost\plugins\DVBViewer\__init__.py", line 355, in SendCommandThroughCOM
File "win32com\client\dynamic.pyc", line 496, in __getattr__
AttributeError: DVBViewerServer.DVBViewer.SendCommand

confirmator
Posts: 22
Joined: Sat Apr 05, 2008 7:10 pm

Re: Fehlermeldung beim Start von EventGhost (0.3.6.1359)

Post by confirmator » Mon Apr 07, 2008 9:32 am

Hast Du EG nach der Installation mindestens 1 mal mit Admin Privilegien gestartet?

tjg
Experienced User
Posts: 67
Joined: Sat Feb 11, 2006 4:11 pm

Re: Fehlermeldung beim Start von EventGhost (0.3.6.1359)

Post by tjg » Mon Apr 07, 2008 9:38 am

Habe es im zweiten Versuch als Admin installiert und auch gestartet,
die Fehlermeldungen sind die gleichen!

confirmator
Posts: 22
Joined: Sat Apr 05, 2008 7:10 pm

Re: Fehlermeldung beim Start von EventGhost (0.3.6.1359)

Post by confirmator » Mon Apr 07, 2008 10:21 am

Seltsam.. bekam auch ähnliche Fehlermeldungen beim Umstieg von der letzten Final (hier keinerlei Fehlermeldungen, auch ohne das einmalige Starten als Admin) auf die aktuelle Beta. Nach dem ersten Start mit Adminrechten war dann aber alles ok.
@Vista x64 SP1

User avatar
Bitmonster
Site Admin
Posts: 2239
Joined: Mon Feb 06, 2006 10:28 pm

Re: Fehlermeldung beim Start von EventGhost (0.3.6.1359)

Post by Bitmonster » Mon Apr 07, 2008 10:23 am

Das ist jetzt aber ein Problem des DVBViewer Plugins.
Please post software-related questions in the forum - PMs will only be answered, if really private, thanks!

confirmator
Posts: 22
Joined: Sat Apr 05, 2008 7:10 pm

Re: Fehlermeldung beim Start von EventGhost (0.3.6.1359)

Post by confirmator » Mon Apr 07, 2008 10:27 am

Achso dann sry für OT, dachte es geht immernoch u.a. um den Fehler im Anfangspost..

tjg
Experienced User
Posts: 67
Joined: Sat Feb 11, 2006 4:11 pm

Re: Fehlermeldung beim Start von EventGhost (0.3.6.1359)

Post by tjg » Mon Apr 07, 2008 12:30 pm

[fixed]

sowohl für Vista SP1 als auch bei WinXP SP2 gibt es keine Startprobleme mehr.

*thx*

Post Reply