Support for XBMC2 plugin (formerly XBMCRepeat)

Questions and comments specific to a particular plugin should go here.

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby blaher » Mon Feb 27, 2017 5:22 am

A brand new install of EG puts this plugin in the XBMCRepeat folder, but when I update to 0.6.33, in my logs it seems to be looking for plugins/xmbc2

Can you please tell me where the 0.6.33 init file is supposed to go, please?
blaher
Experienced User
 
Posts: 463
Joined: Thu Nov 17, 2011 1:27 am

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby jonib » Mon Feb 27, 2017 5:51 am

blaher wrote:but when I update to 0.6.33, in my logs it seems to be looking for plugins/xmbc2
What does the log say? Hmm might be about a xbmc2 dir in %APPPATH% that's for extra data files that holds for example the commands information.

Can you please tell me where the 0.6.33 init file is supposed to go, please?
XBMCRepeat is the correct directory for now.

jonib
XBMC2 plugin to control XBMC. If you want to flatter me Image
jonib
Plugin Developer
 
Posts: 1241
Joined: Thu Mar 26, 2009 9:33 pm
Location: Sweden

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby blaher » Tue Feb 28, 2017 4:55 am

jonib wrote:
blaher wrote:but when I update to 0.6.33, in my logs it seems to be looking for plugins/xmbc2
What does the log say? Hmm might be about a xbmc2 dir in %APPPATH% that's for extra data files that holds for example the commands information.


It was to do with ssdp.log, but I can't seem to replicate it now and the log got deleted. If I start EG with Kodi running, then json events work, but if I don't have it running, then it won't connect. There seems to be more info in the tree than EG's logs, so that's what I've attached. Both debug and log raw events are on.

Can you please tell me where the 0.6.33 init file is supposed to go, please?
XBMCRepeat is the correct directory for now.[/quote]

Thank you. I've renamed it back to that.

Edit: I didn't have 'log debug info' ticked on the EG menu

15:14:42 XBMC2: SSDP: Error in headers: {'USN': ' uuid:d728ddbf-f7bd-0309-f189-54b80a26edf8::urn:schemas-wifialliance-org:service:WFAWLANConfig:1', 'NTS': ' ssdp:alive', 'SERVER': ' Unspecified, UPnP/1.0, Unspecified', 'HOST': ' 239.255.255.250:1900', 'LOCATION': ' http://192.168.0.16:45555/wps_device.xml', 'CACHE-CONTROL': ' max-age=1801', 'Start-line': 'NOTIFY * HTTP/1.1', 'NT': ' urn:schemas-wifialliance-org:service:WFAWLANConfig:1'}
15:14:42 JSON-RPC connect error:
15:14:42 Traceback (most recent call last):
15:14:42 File "C:\Program Files (x86)\EventGhost\plugins\XBMCRepeat\__init__.py", line 2082, in WaitForXBMC
15:14:42 with open(os.path.join(eg.folderPath.RoamingAppData, 'EventGhost', 'plugins', 'XBMC2', 'ssdp.log'), 'a') as f:
15:14:42 IOError: [Errno 2] No such file or directory: u'C:\\Users\\blaher\\AppData\\Roaming\\EventGhost\\plugins\\XBMC2\\ssdp.log'

That's not the correct IP, but changing it from 127.0.0.1 to my actual local IP results in the same error.
Last edited by blaher on Wed Mar 01, 2017 2:57 am, edited 1 time in total.
blaher
Experienced User
 
Posts: 463
Joined: Thu Nov 17, 2011 1:27 am

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby jonib » Tue Feb 28, 2017 7:02 am

blaher wrote:If I start EG with Kodi running, then json events work, but if I don't have it running, then it won't connect.
Do you have this problem even when the debug option is disabled?

That's not the correct IP, but changing it from 127.0.0.1 to my actual local IP results in the same error.
create an empty ssdp.log textfile in "%APPDATA%\EventGhost\plugins\XBMC2\"
Looks like the plugin tries to append to the ssdp.log but doesn't create it if its not there.

jonib
XBMC2 plugin to control XBMC. If you want to flatter me Image
jonib
Plugin Developer
 
Posts: 1241
Joined: Thu Mar 26, 2009 9:33 pm
Location: Sweden

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby blaher » Wed Mar 01, 2017 3:21 am

jonib wrote:
blaher wrote:If I start EG with Kodi running, then json events work, but if I don't have it running, then it won't connect.
Do you have this problem even when the debug option is disabled?


Yes, I just tested it and it's the same problem.

That's not the correct IP, but changing it from 127.0.0.1 to my actual local IP results in the same error.
create an empty ssdp.log textfile in "%APPDATA%\EventGhost\plugins\XBMC2\"
Looks like the plugin tries to append to the ssdp.log but doesn't create it if its not there.[/quote]

Cool, I've done that and it stops the complaining in the log, but nothing is written to ssdp.log. My ssdp discovery service is set to manual in Windows 10, but it is running.
Attachments
Log.txt
(8.48 KiB) Downloaded 52 times
eg tree log.txt
(16.34 KiB) Downloaded 53 times
blaher
Experienced User
 
Posts: 463
Joined: Thu Nov 17, 2011 1:27 am

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby jonib » Thu Mar 09, 2017 5:10 pm

Sorry for the late response, I haven't been feeling up to doing anything useful for the past week.
blaher wrote:Cool, I've done that and it stops the complaining in the log, but nothing is written to ssdp.log. My ssdp discovery service is set to manual in Windows 10, but it is running.

I don't believe the "Windows ssdp discovery service" is used at all for this.

Do you have any of the UPnP options active in Kodi, as that is needed for the plugin to detect Kodi starting.

I'll try to read your logs and see if I can figure out anything else, unfortunately the SSDP is some of the most frustrating things to deal with in the plugin and as I haven't been feeling well for a long time makes it hard for me to deal with, sorry.

jonib
XBMC2 plugin to control XBMC. If you want to flatter me Image
jonib
Plugin Developer
 
Posts: 1241
Joined: Thu Mar 26, 2009 9:33 pm
Location: Sweden

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby denbartman » Tue Mar 21, 2017 8:57 pm

Hi,

I'm having the same problem. When i start Kodi with Eventghost, Eventghost can't control Kodi. When i start eventghost after that kodi is running it can control kodo as it used to.
I just installed Kodi 17.1 and the problem stays.

Thanks for looking in to this...
denbartman
 
Posts: 3
Joined: Tue Mar 21, 2017 8:44 pm

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby jonib » Tue Mar 21, 2017 11:36 pm

denbartman wrote:I'm having the same problem. When i start Kodi with Eventghost, Eventghost can't control Kodi. When i start eventghost after that kodi is running it can control kodo as it used to.
So it did work for you before? What changed? did you update to Kodi17.
I just installed Kodi 17.1 and the problem stays.
I haven't tested with 17 or 17.1, I'll try to update and check if there is anything new.

jonib
XBMC2 plugin to control XBMC. If you want to flatter me Image
jonib
Plugin Developer
 
Posts: 1241
Joined: Thu Mar 26, 2009 9:33 pm
Location: Sweden

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby denbartman » Tue Mar 21, 2017 11:44 pm

jonib wrote:
denbartman wrote:I'm having the same problem. When i start Kodi with Eventghost, Eventghost can't control Kodi. When i start eventghost after that kodi is running it can control kodo as it used to.
So it did work for you before? What changed? did you update to Kodi17.
I just installed Kodi 17.1 and the problem stays.
I haven't tested with 17 or 17.1, I'll try to update and check if there is anything new.

jonib

Yes, I updated from kodi 15 to kodi 17. Has been working fine since 2010 when it was still xbmc.
I added the "EGAppControl_0.3.2" plugin and added a eg restart task after i start kodi. After the restart of eg i get a messag in kodi that it has detected eventghost and the remote actions work fine.
I'm running windows 10 (as a non-admin user) but this hasn't been a problem up till kodi 17.
denbartman
 
Posts: 3
Joined: Tue Mar 21, 2017 8:44 pm

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby jonib » Wed Mar 22, 2017 8:23 am

denbartman wrote:Yes, I updated from kodi 15 to kodi 17. Has been working fine since 2010 when it was still xbmc.
OK
I added the "EGAppControl_0.3.2" plugin and added a eg restart task after i start kodi. After the restart of eg i get a messag in kodi that it has detected eventghost and the remote actions work fine.
OK
I'm running windows 10 (as a non-admin user) but this hasn't been a problem up till kodi 17.
What EventGhost are you using? and are you using the 0.6.33 version of the XBMC2 plugin?

jonib
XBMC2 plugin to control XBMC. If you want to flatter me Image
jonib
Plugin Developer
 
Posts: 1241
Joined: Thu Mar 26, 2009 9:33 pm
Location: Sweden

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby jonib » Wed Mar 22, 2017 10:11 pm

So I tried Kodi 17.1 on Win10 (store version) and there don't seem to be any problem detecting when Kodi starts or stops, so not sure what the problem is.

Any of the UPnP options in Kodis service section needs to be active for the plugin to detect Kodi.
Both "Allow remote control from applications" options need to be enabled.

Check that all IP address and port settings match between the plugin and Kodi.

Maybe a firewall is blocking the communication between Kodi and EventGhost.

jonib
XBMC2 plugin to control XBMC. If you want to flatter me Image
jonib
Plugin Developer
 
Posts: 1241
Joined: Thu Mar 26, 2009 9:33 pm
Location: Sweden

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby blaher » Thu Mar 23, 2017 3:46 am

jonib wrote:Sorry for the late response, I haven't been feeling up to doing anything useful for the past week.
jonib


No worries, thanks for looking whenever you get a chance.

Here are my Kodi settings and I've checked my IP/Port and login name in the EG plugin.
Cheers
Attachments
screenshot002.png
screenshot001.png
screenshot000.png
blaher
Experienced User
 
Posts: 463
Joined: Thu Nov 17, 2011 1:27 am

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby denbartman » Fri Mar 24, 2017 12:21 am

jonib wrote:So I tried Kodi 17.1 on Win10 (store version) and there don't seem to be any problem detecting when Kodi starts or stops, so not sure what the problem is.

Any of the UPnP options in Kodis service section needs to be active for the plugin to detect Kodi.
Both "Allow remote control from applications" options need to be enabled.

Check that all IP address and port settings match between the plugin and Kodi.

Maybe a firewall is blocking the communication between Kodi and EventGhost.

jonib


I did some more testing and updated to the latest version.
Seems an event activating the xbmc tree didn't fire anymore. So the problem had nothing to do with this plugin.
The new version however gives an error on startup (XBMC2: Error opening: actions.dat) but this doesn't seem to cause any problems.

Big thanks anyway for looking in to the problem.
denbartman
 
Posts: 3
Joined: Tue Mar 21, 2017 8:44 pm

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby snack » Mon Mar 27, 2017 12:06 am

I can't get Kodi 17.1 to recognize any of my remote button presses. Kodi 16.x was fine. I upgraded to EventGhost 0.5.0-beta6 and also the __init__.py 0.6.33 but that didn't fix my problem.
Any ideas on what changed between Kodi 16 and 17 to cause EventGhost to not work?
snack
 
Posts: 10
Joined: Mon Sep 17, 2012 1:04 am

Re: Support for XBMC2 plugin (formerly XBMCRepeat)

Postby mywayfr » Mon Mar 27, 2017 7:08 am

Hello,
I've post the message here below on the kodi community support forum, but even after more than 2OO view I've received not an answers...
So is that any help for making it with the xbmc2 plugin on Evenghost?

Many thanks :)
------------------------------------------------------------------------------------------------
Hello,
With a Dvblink Backend, I've created some group for my channel.

It's difficult when I'm on a group with the full guide windows to change group channel.

I must to click on option at the screen bottom then before the left side windows close itself, push "enter" another windows shows up and with the arrows I can change group.

Is that a shortcut on keyboard or remote with Evenghost maybe to do that in one action

Many thanks for anyhelp
--------------------------------------------------------------------------------------------------------
mywayfr
 
Posts: 14
Joined: Fri Apr 06, 2012 8:18 am

PreviousNext

Return to Plugin Support

Who is online

Users browsing this forum: No registered users and 5 guests