SoundGraph iMON HID plugin

Questions and comments specific to a particular plugin should go here.
cmonpellier
Posts: 13
Joined: Sat Mar 20, 2010 1:20 am

Re: SoundGraph iMON HID plugin

Post by cmonpellier » Sat Mar 20, 2010 1:58 am

Hi,

I added the plugin and the Device Id shows up as 0038, Version ID 0001

But then I get an error right away stating 'Error opening HID device: Vendor ID 5570 HID-compliant device

Then System.DeviceRemoved Vid_15c2&Pid_0038

The case is the Antec Remote Black Fusion.

The hardware ID is:
HID\Vid_15c2&Pid_0038&Rev_0001&MI_01
HID_DEVICE_UP:FFCC_U:0001


Any help would be awesome!

Johnson
Posts: 48
Joined: Sun May 24, 2009 9:05 pm

Re: SoundGraph iMON HID plugin

Post by Johnson » Sat Mar 20, 2010 10:29 am

Hi,

What version of EG, Windows are you use?
What version of SoundGraph iMON Manager are installed?
iMON Manager is loaded when error happens?
Are you try to run EG with Administrator rights?
Are you check or not "Use selected device only if connected to current port" or "Use the device with index"?
If yes please uncheck it.


Please try Generic HID plugin (in which my plugin based). Is it work in raw mode?

cmonpellier
Posts: 13
Joined: Sat Mar 20, 2010 1:20 am

Re: SoundGraph iMON HID plugin

Post by cmonpellier » Sat Mar 20, 2010 2:54 pm

Johnson wrote:Hi,

What version of EG, Windows are you use?
EG is 0.3.7.r1436
Windows is XP Pro x64 SP2
Johnson wrote:What version of SoundGraph iMON Manager are installed?
IMonManager ver 7.85.0222 (ANTEC)
iMon Firmware ver 0x380102
LCD HID OEM
Johnson wrote:iMON Manager is loaded when error happens?
No I made sure that it is off. However it does autostart, so the only I've done is to shut it down. Maybe I should uninstall it...
Johnson wrote:Are you try to run EG with Administrator rights?
Yes
Johnson wrote:Are you check or not "Use selected device only if connected to current port" or "Use the device with index"?
If yes please uncheck it.
No I have not checked either of them.
Johnson wrote:Please try Generic HID plugin (in which my plugin based). Is it work in raw mode?
The Generic one has the same error message... In both raw mode or not I get 'Error reading...' or 'Error opening HID Device...'

cmonpellier
Posts: 13
Joined: Sat Mar 20, 2010 1:20 am

Re: SoundGraph iMON HID plugin

Post by cmonpellier » Sat Mar 20, 2010 3:25 pm

ok I tried

- upgrading XP to the latest updates (.Net and some security)
- uninstalling IMonManager
- Reinstalling eventghost

no luck, same error...

Johnson
Posts: 48
Joined: Sun May 24, 2009 9:05 pm

Re: SoundGraph iMON HID plugin

Post by Johnson » Sat Mar 20, 2010 3:34 pm

It look like problem of 64bit system or XP 64bit in HID.py EG module:?

I'm think you must solve problem with Bartman in Generic HID plugin branch.

If you have some programing experience you can examine error code of win32file.CreateFile() in eg\WinApi\HID.py EG module...

cmonpellier
Posts: 13
Joined: Sat Mar 20, 2010 1:20 am

Re: SoundGraph iMON HID plugin

Post by cmonpellier » Sat Mar 20, 2010 6:29 pm

Ok I just posted something on the Generic HID forum, I'll keep you posted.

Is there a way to get extended log or to run it in debug mode to get the error code ?

Johnson
Posts: 48
Joined: Sun May 24, 2009 9:05 pm

Re: SoundGraph iMON HID plugin

Post by Johnson » Sun Mar 21, 2010 2:45 pm

cmonpellier wrote:Is there a way to get extended log or to run it in debug mode to get the error code ?
No.

Johnson
Posts: 48
Joined: Sun May 24, 2009 9:05 pm

Re: SoundGraph iMON HID plugin

Post by Johnson » Sun Mar 28, 2010 3:05 pm

updated

kricker
Experienced User
Posts: 147
Joined: Thu Oct 12, 2006 5:49 am
Contact:

Re: SoundGraph iMON HID plugin

Post by kricker » Sun Mar 28, 2010 4:04 pm

Post removed. No longer relevant.
Last edited by kricker on Sun Mar 28, 2010 4:23 pm, edited 1 time in total.

brand10
Experienced User
Posts: 62
Joined: Mon Mar 29, 2010 10:31 am

Re: SoundGraph iMON HID plugin

Post by brand10 » Mon Mar 29, 2010 10:46 am

It seems as i have the same problem as cmonpellier :(

Exactly the same Hardware, exactly the same Problem with this Soundgraph crap. Sorry to say that, but im really frustrated with this piece of all-time-not-working-Hardware.

Johnson
Posts: 48
Joined: Sun May 24, 2009 9:05 pm

Re: SoundGraph iMON HID plugin

Post by Johnson » Mon Mar 29, 2010 11:09 am

brand10 wrote:It seems as i have the same problem as cmonpellier :(

Exactly the same Hardware, exactly the same Problem with this Soundgraph crap. Sorry to say that, but im really frustrated with this piece of all-time-not-working-Hardware.
Sorry, but it's too hard to debug remotely.

brand10
Experienced User
Posts: 62
Joined: Mon Mar 29, 2010 10:31 am

Re: SoundGraph iMON HID plugin

Post by brand10 » Thu Apr 01, 2010 9:51 am

Which Info's do u need?
With the IRSS from Mediaportal my iMON (Remote and front Knob) is working fine, but i want to use eventghost as the central for all automations.

Johnson
Posts: 48
Joined: Sun May 24, 2009 9:05 pm

Re: SoundGraph iMON HID plugin

Post by Johnson » Fri Apr 02, 2010 8:32 am

brand10 wrote:With the IRSS from Mediaportal my iMON (Remote and front Knob) is working fine
It's great! So it's possible to add support of non-HID iMON to EG.
brand10 wrote:Which Info's do u need?
I've enough info but "remotely" debugging isn't a my choose :wink:
So we are need a programmer with WinAPI and basic Python knowledge to read/write non-HID iMONs.
All examples are in IRSS sources and EG "System" plugin.

brand10
Experienced User
Posts: 62
Joined: Mon Mar 29, 2010 10:31 am

Re: SoundGraph iMON HID plugin

Post by brand10 » Fri Apr 02, 2010 3:31 pm

Johnson wrote:It's great! So it's possible to add support of non-HID iMON to EG.
I thought only USB\VID_15C2&PID_FFDC is a non-HID Device?
My one is USB\VID_15C2&PID_0038 and its listed up as a HID Device in the Device Manager.
Johnson wrote:So we are need a programmer with WinAPI and basic Python knowledge to read/write non-HID iMONs.
All examples are in IRSS sources and EG "System" plugin.
I could try it, but i need the IRSS Sources and i haven't found them. Do u know where they are?

**Update**: I have found it here

Jason404
Posts: 3
Joined: Mon Apr 12, 2010 1:47 pm

Re: SoundGraph iMON HID plugin

Post by Jason404 » Mon Apr 12, 2010 1:50 pm

Can I use this plugin to use the MCE remote with the iMON receiver on my Antec Fusion case? I am new to EventGhost, so I do not know if this sort of thing is possible.

Post Reply