PushBullet plugin (Pako)

Questions and comments specific to a particular plugin should go here.
User avatar
Pako
Plugin Developer
Posts: 2294
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: PushBullet plugin (Pako)

Post by Pako » Fri Jan 13, 2017 6:52 pm

That's weird. For me, it works normally and smoothly.
I do not know how I can help.
One more question: what version EventGhost you use?
I use 0.4.1.r1722.

Pako

shaggy79
Experienced User
Posts: 129
Joined: Sun Jul 13, 2014 4:57 pm

Re: PushBullet plugin (Pako)

Post by shaggy79 » Fri Jan 13, 2017 10:49 pm

Pako wrote:That's weird. For me, it works normally and smoothly.
I do not know how I can help.
One more question: what version EventGhost you use?
I use 0.4.1.r1722.

Pako

I am using the same EG software 0.4.1.r1722 :?: :( :(

martikainen
Posts: 5
Joined: Thu Aug 13, 2015 11:22 am

Re: PushBullet plugin (Pako)

Post by martikainen » Wed Jan 18, 2017 7:03 pm

Awesome plugin Pako! (As always :D)

Just installed it and got some configurations working, but there is one thing i need some help with.

I would like to get a push notice with the results from a payload from the directory watcher plugin.

Logentry in eventghost will be:

DirectoryWatcher.Created(u'Z:\\Movies\Foldername')

And I would like to grab the foldername only and push it to myself, right now I'm using a built in function in another program to email me this as soon as anything is added, but getting a short notice in pushbullet would save me alot of effort :)
I've read through the whole thread but couldn't find anything to help me try build this myself, sorry if it's already been up.

Image

User avatar
Pako
Plugin Developer
Posts: 2294
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: PushBullet plugin (Pako)

Post by Pako » Thu Jan 19, 2017 3:36 pm

DirWatchPushBullet1.png
DirWatchPushBullet1.png (3.68 KiB) Viewed 6187 times
DirWatchPushBullet2.png
DirWatchPushBullet2.png (4.52 KiB) Viewed 6187 times
Is this enough ?

Pako
You know flattr ? You can Image

martikainen
Posts: 5
Joined: Thu Aug 13, 2015 11:22 am

Re: PushBullet plugin (Pako)

Post by martikainen » Thu Jan 19, 2017 5:12 pm

Pako wrote:
DirWatchPushBullet1.png
DirWatchPushBullet2.png
Is this enough ?

Pako
you my dear sir are amazing :) And it was easier than i thought.... Any way to strip the folder location out of of it?

Right now my payload is this
Image

and i would like to remove the Z:\Movies\ part, I've tried learning how to use this kind of tweaks before but i can't get my head around exactly how it works (payloads in eventghost that is..)

Notification right now:
Image

Final results would be
"subject"
Foldername

User avatar
Pako
Plugin Developer
Posts: 2294
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: PushBullet plugin (Pako)

Post by Pako » Thu Jan 19, 2017 5:53 pm

martikainen wrote:Final results would be
"subject"
Foldername
I'm a bit confused.
Maybe it should be "subject" Filename instead of "subject" Foldername ?

In any case, it is also simple.
You may use {eg.event.payload[0][10:]} instead of {eg.event.payload[0]}.

If you insist on "subject" Foldername, then you'd better use the term {eg.event.payload[0][:9]} instead of {eg.event.payload[0]}.

Pako
You know flattr ? You can Image

martikainen
Posts: 5
Joined: Thu Aug 13, 2015 11:22 am

Re: PushBullet plugin (Pako)

Post by martikainen » Fri Jan 20, 2017 8:12 am

Pako wrote:
martikainen wrote:Final results would be
"subject"
Foldername
I'm a bit confused.
Maybe it should be "subject" Filename instead of "subject" Foldername ?

In any case, it is also simple.
You may use {eg.event.payload[0][10:]} instead of {eg.event.payload[0]}.

If you insist on "subject" Foldername, then you'd better use the term {eg.event.payload[0][:9]} instead of {eg.event.payload[0]}.

Pako
Foldername is correct, its what i want :) "Z\Movies\Foldername\lots of files" (thats how the structure looks,Drive:\MainFolder\Subfolder\Files)
So the statement [10:] in {eg.event.payload[0][10:] means that i want to "start" after the 10th character i guess, good to know :)

kamsvag
Posts: 8
Joined: Mon Aug 24, 2015 10:48 am

Re: PushBullet plugin (Pako)

Post by kamsvag » Tue Feb 07, 2017 1:42 am

Ok, so I realy enjoy this plugin of yours. How ever, lately I've been getting some errors...

My EG version is 0.4.1.r1700 with Pushbullet by Pako (0.2.4)

Any ideas?

Code: Select all

02:32:17   PushBullet: Haven't seen a nop lately, reconnecting
02:32:18   PushBullet: WebSocket error: [Errno 1] _ssl.c:480: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version
02:32:18     File "C:\Program Files (x86)\EventGhost\lib26\site-packages\websocket\_app.py", line 186, in _callback
02:32:18       callback(self, *args)
02:32:18     File "C:\Program Files (x86)\EventGhost\plugins\PushBullet\__init__.py", line 1208, in on_error
02:32:18       self.stopWatchdog()
02:32:18     File "C:\Program Files (x86)\EventGhost\lib26\site-packages\websocket\_app.py", line 186, in _callback
02:32:18       callback(self, *args)
02:32:18     File "C:\Program Files (x86)\EventGhost\plugins\PushBullet\__init__.py", line 1213, in on_close
02:32:18       self.plugin.Log(self.plugin.text.wsClosed, 2)
02:32:44   System.Idle
02:32:52   PushBullet: Haven't seen a nop lately, reconnecting
02:32:53   PushBullet: WebSocket error: [Errno 1] _ssl.c:480: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version
02:32:53     File "C:\Program Files (x86)\EventGhost\lib26\site-packages\websocket\_app.py", line 186, in _callback
02:32:53       callback(self, *args)
02:32:53     File "C:\Program Files (x86)\EventGhost\plugins\PushBullet\__init__.py", line 1208, in on_error
02:32:53       self.stopWatchdog()
02:32:53     File "C:\Program Files (x86)\EventGhost\lib26\site-packages\websocket\_app.py", line 186, in _callback
02:32:53       callback(self, *args)
02:32:53     File "C:\Program Files (x86)\EventGhost\plugins\PushBullet\__init__.py", line 1213, in on_close
02:32:53       self.plugin.Log(self.plugin.text.wsClosed, 2)
02:33:16   System.UnIdle
02:33:27   PushBullet: Haven't seen a nop lately, reconnecting
02:33:28   PushBullet: WebSocket error: [Errno 1] _ssl.c:480: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version
02:33:28     File "C:\Program Files (x86)\EventGhost\lib26\site-packages\websocket\_app.py", line 186, in _callback
02:33:28       callback(self, *args)
02:33:28     File "C:\Program Files (x86)\EventGhost\plugins\PushBullet\__init__.py", line 1208, in on_error
02:33:28       self.stopWatchdog()
02:33:28     File "C:\Program Files (x86)\EventGhost\lib26\site-packages\websocket\_app.py", line 186, in _callback
02:33:28       callback(self, *args)
02:33:28     File "C:\Program Files (x86)\EventGhost\plugins\PushBullet\__init__.py", line 1213, in on_close
02:33:28       self.plugin.Log(self.plugin.text.wsClosed, 2)

eventspook
Posts: 23
Joined: Tue Mar 05, 2013 2:50 pm

Re: PushBullet plugin (Pako)

Post by eventspook » Tue Feb 07, 2017 2:09 am

kamsvag wrote:Ok, so I realy enjoy this plugin of yours. How ever, lately I've been getting some errors...

My EG version is 0.4.1.r1700 with Pushbullet by Pako (0.2.4)

Any ideas?

Code: Select all

02:32:17   PushBullet: Haven't seen a nop lately, reconnecting
02:32:18   PushBullet: WebSocket error: [Errno 1] _ssl.c:480: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version
02:32:18     File "C:\Program Files (x86)\EventGhost\lib26\site-packages\websocket\_app.py", line 186, in _callback
02:32:18       callback(self, *args)
02:32:18     File "C:\Program Files (x86)\EventGhost\plugins\PushBullet\__init__.py", line 1208, in on_error
02:32:18       self.stopWatchdog()
02:32:18     File "C:\Program Files (x86)\EventGhost\lib26\site-packages\websocket\_app.py", line 186, in _callback
02:32:18       callback(self, *args)
02:32:18     File "C:\Program Files (x86)\EventGhost\plugins\PushBullet\__init__.py", line 1213, in on_close
02:32:18       self.plugin.Log(self.plugin.text.wsClosed, 2)
02:32:44   System.Idle
02:32:52   PushBullet: Haven't seen a nop lately, reconnecting
02:32:53   PushBullet: WebSocket error: [Errno 1] _ssl.c:480: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version
02:32:53     File "C:\Program Files (x86)\EventGhost\lib26\site-packages\websocket\_app.py", line 186, in _callback
02:32:53       callback(self, *args)
02:32:53     File "C:\Program Files (x86)\EventGhost\plugins\PushBullet\__init__.py", line 1208, in on_error
02:32:53       self.stopWatchdog()
02:32:53     File "C:\Program Files (x86)\EventGhost\lib26\site-packages\websocket\_app.py", line 186, in _callback
02:32:53       callback(self, *args)
02:32:53     File "C:\Program Files (x86)\EventGhost\plugins\PushBullet\__init__.py", line 1213, in on_close
02:32:53       self.plugin.Log(self.plugin.text.wsClosed, 2)
02:33:16   System.UnIdle
02:33:27   PushBullet: Haven't seen a nop lately, reconnecting
02:33:28   PushBullet: WebSocket error: [Errno 1] _ssl.c:480: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version
02:33:28     File "C:\Program Files (x86)\EventGhost\lib26\site-packages\websocket\_app.py", line 186, in _callback
02:33:28       callback(self, *args)
02:33:28     File "C:\Program Files (x86)\EventGhost\plugins\PushBullet\__init__.py", line 1208, in on_error
02:33:28       self.stopWatchdog()
02:33:28     File "C:\Program Files (x86)\EventGhost\lib26\site-packages\websocket\_app.py", line 186, in _callback
02:33:28       callback(self, *args)
02:33:28     File "C:\Program Files (x86)\EventGhost\plugins\PushBullet\__init__.py", line 1213, in on_close
02:33:28       self.plugin.Log(self.plugin.text.wsClosed, 2)
I remember having similar issues a while back. Updating to the latest version of EventGhost and the plugin fixed it for me. I believe the version you're running is close to 2 years old.

chris3g
Posts: 5
Joined: Mon May 08, 2017 2:36 pm

Re: PushBullet plugin (Pako)

Post by chris3g » Mon May 08, 2017 2:40 pm

is this still working for everyone?

i am using EG R1722 and the latest plugin files from the first post. i am able to load the plugin and set my API key but it doesn't seem to do anything after that. Nothing is logged even if increase the logging level to 5. If i try to execute a test push it says "PushBullet: No connectivity, waiting..."

I also noticed that the device name does not appear in my pushbullet account (not sure that it's supposed to, but i assume it is).

Any ideas?

User avatar
Pako
Plugin Developer
Posts: 2294
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: PushBullet plugin (Pako)

Post by Pako » Tue May 09, 2017 4:51 pm

I do not know about any problem. It should work normally (it works for me).

Pako
You know flattr ? You can Image

chris3g
Posts: 5
Joined: Mon May 08, 2017 2:36 pm

Re: PushBullet plugin (Pako)

Post by chris3g » Wed May 10, 2017 5:55 pm

ok, i'm lost then. i tried it on 3 different machines with the same behavior. It could be something i doing wrong, but i'm not sure what else there is to do beyond entering the API key? As an alternative i set up the SMTPd plugin and got that working without any problem, so i know that in general my setup is working. I'd much rather uses pushbullet pushes for my events though than emails :(

mwh
Posts: 2
Joined: Thu May 18, 2017 12:47 pm

Re: PushBullet plugin (Pako)

Post by mwh » Thu May 18, 2017 1:18 pm

chris3g wrote:is this still working for everyone?

i am using EG R1722 and the latest plugin files from the first post. i am able to load the plugin and set my API key but it doesn't seem to do anything after that. Nothing is logged even if increase the logging level to 5. If i try to execute a test push it says "PushBullet: No connectivity, waiting..."

I also noticed that the device name does not appear in my pushbullet account (not sure that it's supposed to, but i assume it is).

Any ideas?
The same thing started happening to me yesterday when I updated to plugin 0.2.18 and changed the encryption password. I did a clean install of EG r1722 and the plugin, even updated the API key, but the "no connectivity" message continues to appear. Reverting to plugin 0.2.16 and updating to EG 0.5.0-rc2 also broke in different ways.

I'm not fluent enough in Python to diagnose the problem. Increasing the logging level doesn't seem to provide any additional context. @Pako, can we check anything in the Python shell that might point to the issue?

User avatar
Pako
Plugin Developer
Posts: 2294
Joined: Sat Nov 11, 2006 1:31 pm
Location: Czech Republic
Contact:

Re: PushBullet plugin (Pako)

Post by Pako » Fri May 19, 2017 4:40 am

I need more information to help.
Please turn on log level 5. Then I need to see the whole log until the error occurs.

I have additional questions. Do you have a Pushbullet desktop client or Chrome extension installed on the same computer as EventGhost?
Does that work flawlessly?

Pako
You know flattr ? You can Image

mwh
Posts: 2
Joined: Thu May 18, 2017 12:47 pm

Re: PushBullet plugin (Pako)

Post by mwh » Fri May 19, 2017 7:57 pm

Pako wrote:I need more information to help.
Please turn on log level 5. Then I need to see the whole log until the error occurs.

I have additional questions. Do you have a Pushbullet desktop client or Chrome extension installed on the same computer as EventGhost?
Does that work flawlessly?
Thanks for the quick reply. I do have the Pushbullet extension installed and working well in Firefox on the same system. EventGhost can send and receive events from other devices/services.

Changing the logging level in the plugin doesn't seem to produce more verbose output. I have an action set up to send a PB notification 15 seconds after EG starts. This is the log output at level 5:

Code: Select all

2017-05-19 12:13:11     Plugin: Log redirector and filter
2017-05-19 12:13:11        NOTICE: LogRedirector started
2017-05-19 12:13:11     Plugin: Webserver
2017-05-19 12:13:11        INFO: Webserver started as unsecured (http://) on port 81
2017-05-19 12:13:11        NOTICE: Persistent values: {}
2017-05-19 12:13:11     Plugin: Speech
2017-05-19 12:13:11     Plugin: PushBullet
2017-05-19 12:13:11     ACTION: Wait: 15.0 sec
2017-05-19 12:13:26     ACTION: PushBullet: Push: note to "Android"
2017-05-19 12:13:26  NOTICE: PushBullet: No connectivity, waiting ...
2017-05-19 12:13:26  EVENT: Main.OnInit
2017-05-19 12:15:00  EVENT: System.Idle

Post Reply